Skip to main content

Lưu ý khi sử dụng thư viện jQuery

Lưu ý khi sử dụng thư viện jQuery

Khác nhau giữa thư viện jQuery 1.x và 2.x

Nếu như Python có Python 2 và 3 được phát triển song song thì thư viện jQuery cũng tương tự, có phiên bản 1.x và 2.x

Mà dân IT như tôi thường có xu hướng sử dụng phiên bản mới nhất vì nghĩ rằng "mới hơn tất nhiên sẽ tốt hơn". Tuy nhiên, sự thật là 2 nhánh jQuery này có sự khác biệt ảnh hướng tới lưu lượng truy cập trang web của bạn. Theo thông tin từ trang chủ jQuery:

jQuery 2.x has the same API as jQuery 1.x, but does not support Internet Explorer 6, 7, or 8. All the notes in the jQuery 1.9 Upgrade Guide apply here as well. Since IE 8 is still relatively common, we recommend using the 1.x version unless you are certain no IE 6/7/8 users are visiting the site.
Như vậy là jQuery 2 giống jQuery 1 trừ việc phiên bản 2 không hỗ trợ trình duyệt IE 6, 7 hoặc 8. Vậy thì bạn nên sử dụng phiên bản nào? Hãy sử dụng các công cụ theo dõi lưu lượng truy cập như Google Analytics chẳng hạn để xác định người dùng của bạn sử dụng trình duyệt nào.
Vấn đề cần lưu ý khi sử dụng thư viện jQuery

Ngoài ra, Google Analytics còn cho bạn biết phiên bản trình duyệt cụ thể mà người dùng đang sử dụng.
Vấn đề cần lưu ý khi sử dụng thư viện jQuery

Như trong hình trên thì tôi có thể biết người dùng truy cập blog tôi có sử dụng IE từ phiên bản 8-11. Như vậy tôi có thể yên tâm sử dụng jQuery 2 vì người dùng IE 6, 7 hầu như là không có. Bạn cũng có thể sử dụng PHP để tự động chèn thư viện jQuery dựa theo phiên bản IE của người dùng:

function include_jquery() {
 if (preg_match('/(?i)msie [6-8]/', $_SERVER['HTTP_USER_AGENT'])) {
  // if IE<=8
  $version = '1.12.2';
 } else {
  // if IE>8
  $version = '2.2.2';
 }
 echo '<script src="//ajax.googleapis.com/ajax/libs/jquery/' . $version . '/jquery.min.js"></script>';
}

Xem đoạn code trên từ GitHub.

Thông tin thêm: Kích cỡ của jQuery 2.x nhẹ hơn 12% so với jQuery 1.x

Share this with your friends
Loading...