Skip to main content

Foxit Reader dính lỗ hổng bảo mật nghiêm trọng

Ứng dụng xem file PDF, Foxit Reader, vừa bị phát hiện dính lỗ hổng nghiêm trọng trong thành phần plug-in, có thể bị khai thác để thực thi các mã tùy chỉnh trên máy tính.

Thông tin chi tiết về lỗ hổng và cách khai thác lỗ hổng đã được hacker độc lập người Ý, Andrea Micalizzi công bố công khai vào tuần trước.

[Hình: foxit.jpg]

Vẫn chưa có bản vá chính thức cho lỗ hổng này, theo một cố vấn tình báo an ninh của hãng bảo mật Secunia. Theo hãng bảo mật này thì lỗ hổng trên là rất quan trọng bởi vì nó có thể được khai thác từ xa để truy cập các hệ thống từ xa.

Theo đại diện các nhà phát triển Foxit cho biết công ty đã xác định được nguyên nhân gây lỗ hổng này và đang bắt tay vào việc tạo ra một bản vá lỗi. Bản vá lỗi dự kiến được phát hành trong tuần tới.

Trong báo cáo từ Secunia, hãng bảo mật này cho biết: “Lỗ hổng được gây ra bởi một lỗi ranh giới trong Foxit Reader liên quan đến plug-in trên trình duyệt (npFoxitReaderPlugin.dll) khi xử lý một URL và có thể bị khai thác để gây lỗi tràn bộ đệm, giống như một tập tin quá dài trong URL. Khi khai thác thành công lỗ hổng, kẻ tấn công có thể thực thi các mã nhị phân từ xa”.

Lỗ hổng này đã được xác nhận trong npFoxitReaderPlugin.dll phiên bản 2.2.1.530, được cài đặt trong Foxit Reader 5.4.4.1128, phiên bản mới nhất của chương trình, tuy nhiên, các phiên bản cũ hơn cũng có thể bị ảnh hưởng, Secunia cho biết.

Theo mặc định, Foxit Reader cài đặt các plug-in cho Mozilla Firefox, Google Chrome, Opera và trình duyệt web Safari nên người dùng cần chú ý.

Trong quá khứ, Foxit Reader đã được đề xuất bởi một số người trong cộng đồng bảo mật như là một thay thế an toàn hơn và ít bị tấn công hơn so với Adobe Reader. Trong thực tế, Foxit, công ty phát triển ứng dụng, tuyên bố trên trang web của mình rằng Foxit Reader là trình đọc PDF an toàn nhất, tốt hơn so với Adobe PDF Reader và Acrobat. Theo công ty thì chương trình được sử dụng bởi hơn 130 triệu người sử dụng.

Chaitanya Sharma, tư vấn nhóm dẫn đầu tại Secunia, cho biết qua email rằng: “Chúng tôi đã xác nhận các lỗ hổng bằng cách sử dụng Firefox, Opera và Safari. Tại thời điểm này, người dùng cần vô hiệu hóa tiện ích này trong trình duyệt và sử dụng các phần mềm khác như Adobe Reader”.

Đại diện Foxit khuyến cáo người dùng nên tránh sử dụng plug-in của Foxit Reader cho trình duyệt Firefox, Chrome, Opera hay Safari, thay vào đó đề nghị sử dụng Internet Explorer để xem các tập tin PDF trực tuyến.


Theo NLD

Share this with your friends
Loading...